Omdat SME 8.0 gebaseerd is om Centos 5, verloopt de support daarop per 31-03-2017. Ik was al een tijdje van plan om te gaan upgraden naar SME 9.0, maar er waren een paar dingen die me daar vanaf hielden: 

  • Het upgrade scenario is een full backup, her-installatie en een restore. Ik voorzag allerlei moeilijke dingen.
  • Ik had in de loop van de jaren van alles er bij geïnstalleerd, dat moest deels opnieuw

Na wat inventarisatie ben ik begonnen op een vrije dag. De backups werkten, die had ik getest door een gedeelte te restoren. De her-installatie liep soepel, maar al snel dook het eerste probleem op.

De USB stick die ik had gebruikt als boot medium bleek deel uit te maken van de RAID array. Zonder de USB stick gaf GRUB een foutmelding, en mijn pogingen om dat er uit te werken lukten niet. Uiteindelijk heb ik SME 9.1 geïnstalleerd door te booten van de USB stick, maar de iso over het internet aan te wijzen. De installatie bug schijnt intussen opgelost te zijn. 

Harddisks kregen een ander devicenaam, twee keer een degraded raid array waarschuwing gehad omdat de USB stick er toch nog in hing ergens, de hardware helemaal schoon gemaakt, 

De restore ging verrassend snel, en al snel had ik het meeste ook weer werkende. Intussen is het een paar weken later en ik heb nog niets gemist, alles dat ik wilde houden is ook echt over. Zelfs mijn web-pagina met een MQT client liep zonder aanpassingen. Bij elkaar een paar uur werk, uitgesmeerd over anderhalve dag.

Intussen heb ik er zelf een paar contribs bij geïnstalleerd:

Het enige dat ik zo los er bij heb gezet:

  • expect
  • netpbm
  • Piwigo
  • Owncloud

En alles loopt weer. Gelijk heb ik een handjevol dingen opgeruimd die in de loop der jaren zijn verzameld. De backup heb ik nu automatisch laten lopen naar een lokale NAS.

Heel blij ben ik met Letsencrypt, eindelijk ben ik verlost van de verplichte acceptatie van de self-signed-certificates. Samen met de redirection naar https per ibay wordt het weer een stukje veiliger.


Hierna volgen wat websites, ik ben al wat aan het proberen. Daar zit nog geen drang achter, alles wat nu draait is nog gesupport en safe.