It's that time again. Changes in Hotmail required a change in Gotmail. The patched version is available here

Update: the official fix is out.

The base was formed by Gotmail 0.82, install that version first. The script gotmail than can be overwritten by this version. Of course the official version will soon appear on the website of Gotmail. This patch came from the patches directory, someone named "cageek" posted it there. Also check the gotmail mailing list.